Noticias|Artículos|Figuras|Enlaces|belenismo.net

Buscar | Estadísticas | Listado de usuarios Foros | Calendarios | Álbumes | Skins
Foro de Belenismo

¿Quieres anunciarte aquí? - contacta con nosotros

Has entrado como invitado. ( Entra | regístrate )

Control de un Belén mediante Arduino

Páginas: < ... 5 6 7 8 9 10 11 >
 

laucsada

Posts: 173
Ubicación: Pamplona



Pastorcillo

Posts: 173

Ubicación: Pamplona

Buenas tardes Alfonso.

Por lo que indicas en tu mensaje está claro que el problema está en la combinación de arduino con el reproductor, ya que el reproductor funciona por separado cuando por medio de pulsadores mandas gnd a sus pines.

Dentro de las posibles causas por las que no se transmite correctamente las órdenes de arduino hay, principalmente, una que nos hemos ido encontrando a lo largo de este último año, tanto otros foreros como yo, y es la versión de la librería DFRobotDFPlayerMini. Comprueba que no estás utilizando la versión 1.0.6. Si es así, vuelve a la 1.0.5 que nos está funcionando bien.

Otro problema suele ser la capacidad de la tarjeta SD. Aunque, en principio admite tarjetas de hasta 32G, ha habido casos en que no la leía, debiendo usarse de 16G

Si nada de esto resuelve el problema, tendríamos que ir al software.

Comentas que la tarjeta tiene un único archivo mp3 que se encuentra en la carpeta 01musica, no en la carpeta raiz. ¿Has tenido en cuenta eso a la hora de que arduino ordene la reproducción?

Si continuas sin resolver el problema, por favor, sube el código que estás usando (supongo que tendrá variaciones sobre el que en su día subí al foro) y le podemos echar un vistazo a ver si nos ofrece más pistas. Sobre todo en relación a los pines usados como TX y RX y la forma de activarlos.

Ya irás informando. Un saludo.

alcabla

Posts: 15
Ubicación: Burriana (Castellon)


Pastorcillo

Posts: 15

Ubicación: Burriana (Castellon)
OK, gracias.
Repasaré todo lo que me indicas.

Bueno en cuanto a la tarjeta no creo que tenga de menos de 32G, vere a ver si mi hija tiene alguna vieja por ahi.

Repasare tambien el codigo y volvere de nuevo con las conexiones.

Primero probare con la librería y de ahi ire viendo.

Gracias por todo, ya te ire diciendo.
A laucsada le gusta esto.
alcabla

Posts: 15
Ubicación: Burriana (Castellon)


Pastorcillo

Posts: 15

Ubicación: Burriana (Castellon)
Buenos días, revise todo lo que me indicaste.

He cambiado la libreria a una versión anterior, he cambiado las conexiones a Arduino a los pines 10 y 11.
Te cuento que con la resistencia se pone en marcha y a los 7 u 8 seg. se corta el sonido.

El DFPlayer lo tengo conectado a fuente a alimentacion externa, hice la prueba y como te comentaba mas arriba se corta el sonido, entonces opté por quitar la resistencia y funciona bien, ya no se corta el sonido.

La tarjeta SD que estoy usando es de 32GB y tengo una pista de sonido y esta grabada en el directorio raiz de la tarjeta.

El esquema es como el que tu hiciste, tengo el Arduino conectado a 12V y el DFPlayer conectado a 5V y la tierra compartida con Arduino.

Y el código que he utililizado para reproducir los sonidos es el que adjunto:




Modificado por alcabla 8/4/2024 14:09




Adjuntos
----------------
Adjuntos sonido_1_pista.ino (0KB - 9 descargas)

laucsada

Posts: 173
Ubicación: Pamplona



Pastorcillo

Posts: 173

Ubicación: Pamplona

Hola Alfonso.

¿Qué duración tiene la pista que tienes grabada en la tarjeta?

Porque en el código le estás diciendo que reproduzca el archivo  de sonido una sola vez, y no en bucle.

Para bucle debería ser:

myDFPlayer.enableLoop();

o

myDFPlayer.loopFolder(0); (para la carpeta raiz)

dependiendo del tipo de rerproductor (unos funcionan perfectamente con la primera y otros no)

Ya me dirás algo.

Un saludo

 

alcabla

Posts: 15
Ubicación: Burriana (Castellon)


Pastorcillo

Posts: 15

Ubicación: Burriana (Castellon)
Hola Iñaki

La duracion es de 2 minutos, el sonido se reproduce hasta el final y luego se para, aun no lo he adaptado para que funcione con las fases porque quiero quitar una parte y añadir otra.

Es que lo estaba haciendo con el Arduino Uno y voy a cambiar la placa al Mega, aunque no tengo mucha cosa para conectar pero creo que es mejor.

No se si se parara por el altavoz que estoy usando es de 16 Ohmios y 0,5W

He encontrado uno en Aliexpress que es de menos Ohmios y a lo mejor funciona mejor, te dejo el enlace a ver que te parece: https://s.click.aliexpress.com/e/_DeCElFT

He estado haciendo unas pruebas y ahora ya no se corta el sonido, pero no tiene la resistencia de 1K puesta.

El altavoz que tengo de 16 Ohmios lo podre utilizar o es mejor comprarme uno de 8 Ohmios.

Ya me dices algo.

Un saludo

laucsada

Posts: 173
Ubicación: Pamplona



Pastorcillo

Posts: 173

Ubicación: Pamplona

Hola Alfonso.

Según he leido por internet, el reproductor puede funcionar con altavoces de 8 o 16 omhios, pero con una potencia máxima de 3w. Por lo que dices el altavoz que estás usando entra dentro de los parámetros, por lo que no debe ser un problema.

La razón de ser de la resistencia en serie en la conexión de arduino (TX) al reproductor (RX) creo que, en principio, es para reducir el voltaje de la señal de arduino (5v), pero ya estamos alimentando el reproductor con 5v, por lo que supongo que no hay ningún problema si no se pone.

Me parece que no he podido aportarte mucho.

Un saludo.

alcabla

Posts: 15
Ubicación: Burriana (Castellon)


Pastorcillo

Posts: 15

Ubicación: Burriana (Castellon)
Hola Iñaki.

Si me has dejado claro que el altavoz puede valer, entonces por baratos que son por Inetrnet, ya me quedo con el que tengo que se escucha muy bien.

Si el modulo DFPlayer lo alimento aparte del Arduino con un transformador de 5V.

Y referente a la resistencia ya he probado varias veces y no le pasa nada al Arduino, buscando por Internet he visto que en un caso he leido un articulo en el cual lo alimentaban de forma externa y en el croquis no llevaba resistencia, osea que de momento lo dejo asi.

Ahora estoy cambiando en el codigo los pines para ponerlo a funcionar con el Mega, ya tengo hecha la iluminacion y un par de motores de 220V a traves del un modulo rele solido, uno que es la era con el trillo y el otro un horno, dando vueltas el pan con imitacion de fuego dentro, tambien voy a preparar el del molino del aceite.

Tengo varios motores pequeños de 5V y 12V que tambien hare algo con ellos pero a traves de un modulo rele optoacoplador, de momento me he hecho un modulo para reducir la velocidad de giro en el cual puedo añadir varios motores y ya si me alcanza el tiempo vere de ponerlos tambien y si no para el proximo año,

Gracias por todo ya te ire informando y cuando tenga el codigo finalizado lo subire aqui por si a alguien puede interesarle, que ya te comente que es una cosa sencilla solamente con dos fases, noche y dia pero como se desvanecen las luces pues tambien estará el anochecer y amanecer, bueno o lo que salga, pero el codigo es sencillo.

Bueno que tengas un excelente dia y ya seguimos hablando.

Un saludo
A laucsada le gusta esto.
Páginas: < ... 5 6 7 8 9 10 11 >
Saltar al foro :
Buscar en este foro
Versión Impresa
Enviar un mail con el enlace a este tema

(Borrar todas las cookies grabadas por este sitio)
Ejecutándose MegaBBS ASP Forum Software
© 2002-2024 PD9 Software