Noticias|Artículos|Figuras Exclusivas|Enlaces|belenismo.net

Buscar | Estadísticas | Listado de usuarios Foros | Calendarios | Álbumes | Skins
Foro de Belenismo

¿Quieres anunciarte aquí? - contacta con nosotros

Has entrado como invitado. ( Entra | regístrate )

Las contestaciones a posts se cambian de hilo

Páginas: 1
 

Drake

Posts: 3421
Ubicación: Barcelona



Pastorcillo

Posts: 3421

Ubicación: Barcelona
Me ha sucedido un par de veces que cuando constesto a algún mensaje, en vez de publicarse en donde pincho la respuesta, me pasa a otro hilo totalmente diferente, y si lo intento volver a enviar, siempre va a ese mismo hilo distinto. Ahora estaba contestando en el belén de VJM y todo el rato la respuesta ha ido al hilo "belén en una botella". ¿Es algún error del mecanismo del foro? ¿le pasa a alguien más?

Drake

Posts: 3421
Ubicación: Barcelona



Pastorcillo

Posts: 3421

Ubicación: Barcelona
Amigo Iñigo, en mira el hilo de las figuras de la colección del prado y verás que han ido a parar un montón de respuestas de otros hilos. Pasa algo raro.

inigomena

Posts: 4299
Ubicación: Pamplona



Herodes

Posts: 4299

Ubicación: Pamplona
Es un tema que vengo observando desde hace un tiempo, y es bastante complicado porque no parece ser determinista, es decir, no pasa en todos los casos ni a todos los usuarios. Sin embargo, parece que a algunos en concreto (jbr, Drake) os ocurre con más frecuencia. También parece que los posts "locos" tienden a irse a los mismos hilos (el de la colección de DelPrado acumula varias respuestas de diferentes hilos). Sería bueno saber algunos datos de aquellos a quienes os ha ocurrido esto, para tratar de trazar la causa:

- Dispositivo utilizado (ordenador, tablet, móvíl) y sistema operativo
- Navegador
- ¿Cómo enviáis la respuesta? ¿Mediante la caja de respuestas al final del hilo, pulsando en el botón de responder al tema, pulsando en el botón de responder a un mensaje, citando el mensaje...? ¿Lo hacéis siempre igual? ¿Es posible que de alguna de las maneras se dé el error y de las otras no?
- Si para responder pulsáis en un botón de "respuesta", en la página de redacción de la respuesta, ¿os aparece correctamente el título en "Posteando una respuesta a: .......... ", o ya aparece el del hilo erróneo?

Voy a intentar meter marcas en el código para tratar de detectar dónde "salta" el mensaje de un hilo a otro, os diré si hay alguna otra cosa en la que podáis fijaros.

Un saludo y gracias
jbr_belenes

Posts: 1389
Ubicación: ---- Gran Canaria


Pastorcillo

Posts: 1389

Ubicación: ---- Gran Canaria
Hola. En estos momentos no tengo ningún problema.

inigomena

Posts: 4299
Ubicación: Pamplona



Herodes

Posts: 4299

Ubicación: Pamplona
Hola a todos, creo que he dado con la causa del problema y, con un poco de suerte, lo habré solucionado.
Contrariamente a lo que yo decía, y como suele pasar en informática, el error sí era determinista, y "por suerte" se debía a una metida de gamba mía en los añadidos que hice no hace mucho para que salgan el panel de última actividad y el de notificaciones. En este último, en concreto, al pinchar en una de las notificaciones, se abría la página del hilo correspondiente, pero con una referencia interna a un mensaje distinto al que se refería la notificación. Al responder, la respuesta se iba al hilo de ese mensaje y no al que debía. Lo raro era que la página del hilo inicialmente se abría bien, pero se quedaba esa referencia "fantasma" que era la que luego provocaba el fallo al enviar una respuesta. Y como era necesaria una sucesión de acciones tan concreta, parecía producirse de manera aleatoria.

Espero, como digo, que el problema se haya solucionado, y no volvamos a sufrir estos mosqueos .

Un saludo
A Drake, felorz17 y jbr_belenes les gusta esto.
Páginas: 1
Saltar al foro :
Buscar en este foro
Versión Impresa
Enviar un mail con el enlace a este tema

(Borrar todas las cookies grabadas por este sitio)
Ejecutándose MegaBBS ASP Forum Software
© 2002-2020 PD9 Software