Las contestaciones a posts se cambian de hilo
Drake

Posts: 3508
Ubicación: Barcelona
Drake
29/12/2018 00:16


Pastorcillo

Posts: 3508

Ubicación: Barcelona
Amigo Iñigo, en mira el hilo de las figuras de la colección del prado y verás que han ido a parar un montón de respuestas de otros hilos. Pasa algo raro.
Drake

Posts: 3508
Ubicación: Barcelona


Pastorcillo

Posts: 3508

Ubicación: Barcelona
Me ha sucedido un par de veces que cuando constesto a algún mensaje, en vez de publicarse en donde pincho la respuesta, me pasa a otro hilo totalmente diferente, y si lo intento volver a enviar, siempre va a ese mismo hilo distinto. Ahora estaba contestando en el belén de VJM y todo el rato la respuesta ha ido al hilo "belén en una botella". ¿Es algún error del mecanismo del foro? ¿le pasa a alguien más?
Parte superior de la página Parte inferior de la página
Parte superior de la página Parte inferior de la página

inigomena

Posts: 4317
Ubicación: Pamplona
inigomena
29/12/2018 09:50



Herodes

Posts: 4317

Ubicación: Pamplona
Es un tema que vengo observando desde hace un tiempo, y es bastante complicado porque no parece ser determinista, es decir, no pasa en todos los casos ni a todos los usuarios. Sin embargo, parece que a algunos en concreto (jbr, Drake) os ocurre con más frecuencia. También parece que los posts "locos" tienden a irse a los mismos hilos (el de la colección de DelPrado acumula varias respuestas de diferentes hilos). Sería bueno saber algunos datos de aquellos a quienes os ha ocurrido esto, para tratar de trazar la causa:

- Dispositivo utilizado (ordenador, tablet, móvíl) y sistema operativo
- Navegador
- ¿Cómo enviáis la respuesta? ¿Mediante la caja de respuestas al final del hilo, pulsando en el botón de responder al tema, pulsando en el botón de responder a un mensaje, citando el mensaje...? ¿Lo hacéis siempre igual? ¿Es posible que de alguna de las maneras se dé el error y de las otras no?
- Si para responder pulsáis en un botón de "respuesta", en la página de redacción de la respuesta, ¿os aparece correctamente el título en "Posteando una respuesta a: .......... ", o ya aparece el del hilo erróneo?

Voy a intentar meter marcas en el código para tratar de detectar dónde "salta" el mensaje de un hilo a otro, os diré si hay alguna otra cosa en la que podáis fijaros.

Un saludo y gracias
Parte superior de la página Parte inferior de la página
jbr_belenes

Posts: 1395
Ubicación: ---- Gran Canaria
jbr_belenes
30/12/2018 04:03


Pastorcillo

Posts: 1395

Ubicación: ---- Gran Canaria
Hola. En estos momentos no tengo ningún problema.
Parte superior de la página Parte inferior de la página

inigomena

Posts: 4317
Ubicación: Pamplona
inigomena
7/1/2019 21:35



Herodes

Posts: 4317

Ubicación: Pamplona
Hola a todos, creo que he dado con la causa del problema y, con un poco de suerte, lo habré solucionado.
Contrariamente a lo que yo decía, y como suele pasar en informática, el error sí era determinista, y "por suerte" se debía a una metida de gamba mía en los añadidos que hice no hace mucho para que salgan el panel de última actividad y el de notificaciones. En este último, en concreto, al pinchar en una de las notificaciones, se abría la página del hilo correspondiente, pero con una referencia interna a un mensaje distinto al que se refería la notificación. Al responder, la respuesta se iba al hilo de ese mensaje y no al que debía. Lo raro era que la página del hilo inicialmente se abría bien, pero se quedaba esa referencia "fantasma" que era la que luego provocaba el fallo al enviar una respuesta. Y como era necesaria una sucesión de acciones tan concreta, parecía producirse de manera aleatoria.

Espero, como digo, que el problema se haya solucionado, y no volvamos a sufrir estos mosqueos .

Un saludo
A Drake, felorz17 y jbr_belenes les gusta esto.
Parte superior de la página Parte inferior de la página